Edgar Systems Not Disseminating to PDS

Incident Report for Workiva

Resolved

Between 5:02am CST to 6:41am CST, Workiva experienced intermittent issues where SEC filings were getting stuck in RETRIEVING_STATUS. This incident is now resolved. Filings are being received as normal. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Jan 12, 2026 - 18:25 UTC

Update

Technical difficulties with the SEC EDGAR system continues. For additional status, please reference https://www.sec.gov/submit-filings/edgar-news-announcements
Posted Jan 12, 2026 - 16:12 UTC

Identified

Technical difficulties with the SEC EDGAR system are currently disseminating filings to the Public Dissemination Service (PDS). As a result, submissions that have been accepted are not being reflected on PDS. . For additional status, please reference https://www.sec.gov/submit-filings/edgar-news-announcements
Posted Jan 12, 2026 - 14:06 UTC
This incident affected: Third Party Provider: U.S. Securities and Exchange Commission.