EDGAR SEC Filing Outage

Incident Report for Workiva

Resolved

This incident has been resolved.
Posted May 29, 2026 - 17:46 UTC

Identified

Technical difficulties with the SEC EDGAR system are currently preventing EDGAR filers (including filers using Wdesk) from filing successfully. For additional status, please reference https://www.sec.gov/submit-filings/edgar-news-announcements
Posted May 29, 2026 - 15:49 UTC
This incident affected: Third Party Provider: U.S. Securities and Exchange Commission.