Filing through Workiva unavailable
Incident Report for Workiva
Resolved
We continue to observe recovery and filings are being received as normal. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Apr 04, 2024 - 12:18 UTC
Investigating
We are investigating reports that users are unable to submit filings to the U.S. Securities and Exchange Commission via Workiva.

The SEC is currently operational and we advise our customers to file using EDGAR Online in the meantime. For guidance on this process, please consult our Support Center article: Workiva Backup Filing Procedure.

We continue to investigate this issue and will provide an update to you as soon as possible.
Posted Apr 04, 2024 - 11:41 UTC
This incident affected: Workiva Platform (US) (Reporting (XBRL, Filing, Section 16)).