Latency with Platform gestures

Incident Report for Workiva

Resolved

Between 10:40 and 13:50 Central time customers may have experienced intermittent latency when using the platform in the US production region. Reports show that the incident is now resolved. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Apr 03, 2024 - 20:31 UTC

Monitoring

Mitigating steps have been taken. Reports confirm users should no longer be experiencing issues. We will continue to monitor the situation closely and provide updates as soon as possible. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Apr 03, 2024 - 19:15 UTC

Investigating

We are currently investigating an issue with latency when editing documents, spreadsheets and presentations. We will provide an update as soon as possible.
Posted Apr 03, 2024 - 18:42 UTC
This incident affected: Workiva Platform (EU) (Productivity (Documents, Spreadsheets, Charts, Presentations)).