Mitigating steps have been taken. We will continue to monitor the situation closely and provide updates as soon as possible. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Mar 06, 2026 - 11:58 UTC
Identified
We have currently identified reports that some users are experiencing a SSO (Single Sign-On) login loop when attempting to login to the Workiva platform. While our team works towards a resolution, we recommend the affected users to try logging in with their username and password rather than via SSO, if possible. We will provide another update as soon as possible.
Posted Mar 06, 2026 - 11:03 UTC
Investigating
We are currently investigating reports that some users are experiencing issues with SSO login. We will provide an update as soon as possible. *This issue is impacting users on app.wdesk and eu.wdesk.
Posted Mar 06, 2026 - 10:17 UTC
This incident affects: Workiva Platform (US) (Access and Administration (Login, Home, Workspaces)) and Workiva Platform (EU) (Access and Administration (Login, Home, Workspaces)).