SEC Technical Difficulties
Incident Report for Workiva
Resolved
Between 2/16/2024 10:15 AM CDT to 2/16/2024 12:58 PM CDT, Workiva experienced technical difficulties with the SEC EDGAR system that prevented/limited EDGAR filers (including filers using Wdesk) from filing successfully. This incident is now resolved. Filings are being received as normal. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Feb 16, 2024 - 17:37 UTC
Identified
Technical difficulties with the SEC EDGAR system are currently preventingEDGAR filers (including filers using Wdesk) from filing successfully. For additional status, please reference https://www.sec.gov/filergroup/announcements.
Posted Feb 16, 2024 - 16:36 UTC
This incident affected: Workiva Platform (US) (Reporting (XBRL, Filing, Section 16)), Workiva Platform (EU) (Reporting (XBRL, Filing, Section 16)), and Workiva Platform (APAC) (Reporting (XBRL, Filing, Section 16)).