SEC Filings stuck in "Retrieving status from SEC"

Incident Report for Workiva

Resolved

The incident regarding SEC filings getting stuck in "Retrieving status from the SEC" is now resolved.

As a reminder, if you received an accession number, you should take no further action on your filing.
Posted Feb 03, 2025 - 17:25 UTC

Monitoring

The SEC has recovered fully and filings are currently processing as expected again.

Customers who previously received an accession number do not need to take any action, their filings will process normally. Please review status updates on www.sec.gov/submit-filings/edgar-news-announcements


We will monitor for 30 minutes to ensure full recovery.
Posted Feb 03, 2025 - 16:28 UTC

Investigating

We have identified that the SEC is currently experiencing technical difficulties. This is resulting in filing submissions not reflecting correctly that they have been accepted.
In the Workiva platform, this may appear as a filing stuck in "Retrieving Status" message.

Users that have received an accession number should not take further action and wait for SEC recovery.

Please review SEC status updates on: www.sec.gov/submit-filings/edgar-news-announcements
Posted Feb 03, 2025 - 15:38 UTC
This incident affected: Third Party Provider: U.S. Securities and Exchange Commission.