KvK Filings Not Received

Incident Report for Workiva

Resolved

Workiva monitoring shows that the incident is now resolved. However, if you continue to experience any issues, please contact Workiva Support, 1-800-706-6526, or one of our international toll-free numbers.
Posted Sep 09, 2026 - 08:16 UTC

Identified

Technical difficulties with the Logius/DigiPort system are currently preventing KvK filers using Workiva from filing successfully. For additional status, please reference https://www.logius.nl/storingen-en-onderhoud.
Posted Sep 08, 2026 - 16:33 UTC
This incident affected: Workiva Platform (US) (Reporting (XBRL, Filing, Section 16)), Workiva Platform (EU) (Reporting (XBRL, Filing, Section 16)), Workiva Platform (APAC) (Reporting (XBRL, Filing, Section 16)), Third Party Provider: Google®, Amazon®, ISP, Other, and Workiva Platform (Canada) (Reporting (XBRL, Filing, Section 16)).