Between approximately 8:48 AM UTC to 09:12 AM UTC Workiva experienced an issue impacting the service across our production environments. This was related to an incident with a third party provider, CloudFare. The incident has since been addressed and we have seen recovery. Reports show the Workiva platform is operational. However, if you continue to experience issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Dec 05, 2025 - 12:32 UTC
Monitoring
Reports confirm that the Workiva platform is recovering. We will continue to monitor closely and provide updates as they become available. If users are still experiencing any performance issues, please contact the Workiva Support Team.
We currently are observing recovery on all our environments and are monitoring the services.
The incident appears to be related to an issue with one of our third party providers, CloudFare, which has been mitigated at the moment, according to their external communication.
Posted Dec 05, 2025 - 09:55 UTC
This incident affected: Third Party Provider: Google®, Amazon®, ISP, Other.