Production/Sandbox application slowness

Incident Report for Workiva

Resolved

At approximately 1PM CDT on 8/21, we experienced intermittent slowness in the US Workiva Platform. Reports show that the incident is now resolved. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Aug 21, 2025 - 22:05 UTC

Monitoring

Our monitoring systems indicating recovery as of approximately 2:15PM CDT. As for the root cause, a networking vendor has acknowledged an incident and has made traffic routing adjustments to resolve the issue. We will continue to monitor the situation and provide an update if additional issues are observed within the Workiva platform. If you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Aug 21, 2025 - 20:30 UTC

Investigating

We are currently investigating reports that some users of the US Workiva Platform may be experiencing intermittent slowness. The issue has been identified and we are working on a remediation. We will provide an update as soon as possible.
Posted Aug 21, 2025 - 18:52 UTC
This incident affected: Workiva Platform (US) (Access and Administration (Login, Home, Workspaces), Productivity (Documents, Spreadsheets, Charts, Presentations), Linking, Notifications and Comments, Import and Export, Reporting (XBRL, Filing, Section 16), Processes (Process Builder, Integrated Automation, Tasking), Controls and Audit, Data Management Suite (Wdata, Chains, Data Prep), ESG (Program & Explorer), API Infrastructure, Mobile).