Workiva Outage impacting app.wdesk.com

Incident Report for Workiva

Resolved

On March 30th, 2026, Workiva experienced an outage with one of it's services resulting in users not being able to access our US Production environment. Reports show the Workiva platform is operational.

However, if you continue to experience issues, please submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Mar 30, 2026 - 21:13 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 30, 2026 - 20:48 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 30, 2026 - 20:14 UTC

Monitoring

Reports confirm that the Workiva platform is recovering. Some users may continue to experience degraded performance. We will continue to monitor closely and provide updates as they become available.
Posted Mar 30, 2026 - 17:56 UTC

Investigating

We are investigating reports that the Workiva platform is failing to load. We will provide an update as soon as possible.

*This issue is impacting users on app.wdesk.
Posted Mar 30, 2026 - 17:38 UTC
This incident affected: Third Party Provider: Google®, Amazon®, ISP, Other.