On March 31st, 2026, the SEC experienced a technical issue resulting in customers not seeing their filing status to the U.S Securities and Exchange Comission. This incident is now resolved. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Mar 31, 2026 - 13:10 UTC
Update
Reports confirm that filings are being received by the U.S. Securities and Exchange Commission. We will continue to monitor throughout the day and provide updates when available.
Posted Mar 31, 2026 - 08:17 UTC
Monitoring
We are seeing a slow recovery with submissions not getting a status from the SEC. Some previous filings stuck in RETRIEVING_STATUS, have now been processed. Filings can still be submitted like normal. However, after the submission the SEC isn't immediately processing them and updating the status of those filings.
Our internal software is still continually checking for status updates and will update automatically (given it's within 18hours of the filing submission) when the SEC resolves the issue on their end.
Posted Mar 30, 2026 - 20:11 UTC
Investigating
We are investigating reports that customers cannot see their filing status to the U.S. Securities and Exchange Commission. Filings can be submitted as normal. Workiva will continually check for status and will update automatically when the SEC issue is resolved.
Technical difficulties with the SEC EDGAR system are currently were posted with an incorrect or missing country code. The SEC EDGAR team is working to correct all impacted filings. For additional status, please reference https://www.sec.gov/submit-filings/edgar-news-announcements
Posted Mar 30, 2026 - 19:15 UTC
Investigating
We are investigating reports that customers cannot see their filing status to the U.S. Securities and Exchange Commission. The SEC is aware of the issue and will provide an update to us shortly.
We will provide an update to you as soon as we have more details.