Between approximately 4:05 AM CT to 7:58 AM CST, we experienced an issue with an internal platform service that caused intermittent problems for some users. Reports show that the incident is now resolved. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Jul 29, 2024 - 17:35 UTC
Monitoring
Recovery is currently being observed, we continue to monitor the situation.
Posted Jul 29, 2024 - 14:09 UTC
Investigating
We're seeing intermittent issues with customers performing actions in the platform. Customers who hit the issue will hit an error saying "Sorry, something went wrong and we couldn't save your most recent changes. Refresh to continue editing."
Posted Jul 29, 2024 - 12:53 UTC
This incident affected: Workiva Platform (US) (Access and Administration (Login, Home, Workspaces), Productivity (Documents, Spreadsheets, Charts, Presentations)).