SEC Filings stuck in "Retrieving status"

Incident Report for Workiva

Resolved

Beginning on 3/28/2025 at approximately 6:30am ET to 11:00am ET, Workiva filing was impacted by technical difficulties on the SEC submissions system. This incident is now resolved. Filings are being received as normal. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Mar 31, 2025 - 13:01 UTC

Update

We have identified that the SEC is currently experiencing technical difficulties. This is resulting in filing submissions not reflecting correctly that they have been accepted.

In the Workiva platform, this may appear as a filing stuck in "Retrieving Status" message.

Users that have received an accession number should not take further action and wait for SEC recovery.

Please review SEC status updates on: www.sec.gov/submit-filings/edgar-news-announcements
Posted Mar 28, 2025 - 14:18 UTC

Identified

We have identified that the SEC is currently experiencing technical difficulties. This is resulting in filing submissions not reflecting correctly that they have been accepted.

In the Workiva platform, this may appear as a filing stuck in "Retrieving Status" message.

Users that have received an accession number should not take further action and wait for SEC recovery.

Please review SEC status updates on: www.sec.gov/submit-filings/edgar-news-announcements
Posted Mar 28, 2025 - 14:12 UTC

Investigating

We have received multiple reports that filings are being processed very slowly and staying in 'retrieving status' for extended periods of time. Filers should refrain from attempting to file again as it we are observing that in most instances the filings are completed as expected after the longer processing time. We are currently investigating.
Posted Mar 28, 2025 - 13:19 UTC
This incident affected: Third Party Provider: U.S. Securities and Exchange Commission.