Workiva Outage impacting app.wdesk.com

Incident Report for Workiva

Resolved

Workiva monitoring shows that the incident is now resolved. However, if you continue to experience any issues, please contact Workiva Support, 1-800-706-6526, or one of our international toll-free numbers.
Posted Jun 22, 2026 - 18:47 UTC

Monitoring

Cloudflare has take steps to mitigate the problem and users should no longer be experiencing issues. We will continue to monitor the situation closely and provide updates as soon as possible. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Jun 22, 2026 - 17:01 UTC

Update

We have confirmed the Workiva platform is being affected by an issue at Cloudflare. They are working to return to normal operations as quickly as possible. Only certain regions are impacted.

For additional status, please reference https://new.cloudflarestatus.com/
Posted Jun 22, 2026 - 15:32 UTC

Identified

We have confirmed the Workiva platform is being affected by an issue with Cloudflare. We are communicating with them and are working to return to normal operations as quickly as possible. Only certain regions are impacted.

For additional status, please reference https://www.cloudflarestatus.com/
Posted Jun 22, 2026 - 14:25 UTC

Investigating

We are investigating reports that the Workiva platform is failing to load. We will provide an update as soon as possible.

This issue is impacting users on app.wdesk.com
Posted Jun 22, 2026 - 14:01 UTC
This incident affected: Workiva Platform (US) (Access and Administration (Login, Home, Workspaces), Productivity (Documents, Spreadsheets, Charts, Presentations), Linking, Notifications and Comments, Import and Export, Reporting (XBRL, Filing, Section 16), Processes (Process Builder, Integrated Automation, Tasking), Controls and Audit, Data Management Suite (Wdata, Chains, Data Prep), Sustainability Reporting (Program & Explorer), Carbon, API Infrastructure, Mobile) and Third Party Provider: Google®, Amazon®, ISP, Other.