Customer Support Line Down

Incident Report for Workiva

Resolved

Reports show that the incident is now resolved. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Sep 15, 2023 - 15:53 UTC

Investigating

We are currently experiencing technical difficulties with our phone system. To contact us via phone, reach out to our alternative number, 1-877-201-6022. Please rest assured that our team is working diligently to resolve this issue as quickly as possible.

We are here to support you through alternative channels as well:

Support Portal: For any inquiries, assistance, or support requests, please visit our Support Portal at https://support.workiva.com. Our dedicated support team is ready to assist you 24/7 through this platform.

Live Chat: You can also reach out to us via our Live Chat feature, assessable on the left side panel once logged into Wdesk.

We will provide an update as soon as possible.
Posted Sep 15, 2023 - 15:09 UTC
This incident affected: Third Party Provider: Google®, Amazon®, ISP, Other.