Activity Logs

Incident Report for Workiva

Monitoring

Mitigating steps have been taken. Reports confirm users should no longer be experiencing issues. We will continue to monitor the situation closely and provide updates as soon as possible. However, if you continue to experience any issues, submit a ticket to our Workiva Support Team, call 1-800-706-6526, or contact one of our international toll-free numbers.
Posted Jan 14, 2026 - 20:24 UTC

Update

Our team continues to work towards a resolution. We will provide another update once more information becomes available.
Posted Jan 13, 2026 - 16:38 UTC

Identified

We have currently identified reports that some users are experiencing a delay in the US Production region with user activity logs. A release is scheduled for later this evening. We will provide an update tomorrow morning.
Posted Jan 12, 2026 - 23:18 UTC

Investigating

As of 12:28 PM CST, we are experiencing delays in the US Production region with user activity logs. Engineering is currently investigating. We will provide an update as soon as possible.
Posted Jan 12, 2026 - 22:08 UTC
This incident affects: Workiva Platform (US) (Access and Administration (Login, Home, Workspaces)).